PDA

Просмотр полной версии : LG Nexus 5 проблема со звуком


DVD-ROMa
02.07.2015, 22:51
Здравствуйте! Имеется телефон LG Nexus 5. Проблема со звуком. Появилась после подключения телефона к микшеру аудиосистемы. Системные звуки на внешнем динамике есть, если включить аудио файл, то ничего не работает. При подключении гарнитуры звук есть в одном левом ухе, громкость явно не заводская (не слишком слабо, но явно не на всю мощность).
Также проблемы с микрофоном, его ели слышно.

Был заменен аудио кодек WCD9320 - результат тот же.

Подозрение на MAX14628 (U10001). Обвязку посмотрел - в норме.

Прав ли я? Может кто сталкивался с подобным?

Спасибо!

Добавлено через 2 часа 8 минут
При вызове или приеме вызова слуховой динамик и микрофон не работают. В гарнитуре работает микрофон и 1 динамик.

Sergey
03.07.2015, 03:39
Подозрение на MAX14628 (U10001). Обвязку посмотрел - в норме.
Думаю нет, она отвечает за определение подключенной гарнитуры.

Надо для начала поменять FSA2269UMX (U10003), она коммутирует сигналы наушников.

DVD-ROMa
03.07.2015, 16:00
Спасибо, попробую поменять FSA2269UMX. Даже при желании найти MAX14628 (U10001) практически не реально, нужно искать донор. По результатам отпишу. Спасибо!

DVD-ROMa
08.08.2015, 16:42
Замена FSA2269UMX не решила проблему. Какие есть у кого идеи или опыт? Спасибо!

DVD-ROMa
14.08.2015, 02:10
Снял микросхему U10002 (FSA5157L6X). Это переключатель между динамиком и динамиками гарнитуры (блок схему прикрепляю). Без этой микросхемы звук выводится на динамик телефона, микрофон телефона работает, звонки работают. В этой части все прекрасно.

Ели подключить гарнитуру, то она не работает, что вполне логично. Если кинуть перемычку между контактами А и В0, то все хорошо, при подключении гарнитура работает, но только на одно левое ухо. Звук стал громче, чем при первоначальных симптомах, но почему не работает один динамик я не могу понять.

Прошу помощи, всем спасибо!

DVD-ROMa
26.09.2015, 18:14
Заменил U10002 (FSA5157L6X). Но в гарнитуре всеравно работало только левое ухо. Было обнаружено, что резисторы R10037 и R100388 имеют отличные от мануала параметры (740 кОм и 0.7кОм). Вот с 0.7 кОм левое ухо и работало. По схеме резисторы на 8.2 Ом. Были заменены на 10 Ом. Теперь все отлично работает. Всем большое спасибо за участие!